You see "All x of the entitlements for serial xxx-xxx-xxxxxx-xxxx have already been claimed." when trying to activate a Redgate Monitor license by entering the serial key. This can occur if user emails have previously been added to it, although the ability to add users to a Redgate Monitor license has now been fixed there may be users left on a license from before the fix was pushed out (more likely with older licenses) so that is still something to keep in mind. Can also occur when trying to assign spare entitlements on an existing serial key-activated license to servers on a new base monitor or if you are re-activating a key after a migration but did not deactivate the key from the original installation.
In either case, you can only encounter this error message on Redgate Monitor when doing serial key activation. If you're on v11.2.3 or later, you will be able to avoid this issue if you switch from serial keys to licenses allocated on redgate.com.
This article covers the cause and resolutions of this error when:
- Activating a new license or newly added entitlements
- Allocating an existing license to servers on new base monitor
Activating a new license or newly added entitlements
On allocating your new license, or new entitlements recently added to an existing license, on the Configuration > Licensing page in Redgate Monitor, you might see an error connecting to the Redgate activation server ("The remote server returned an error: (400) Bad Request") and after the initial steps of a manual activation, the underlying error:
Your activation failed
All x of the entitlements for serial xxx-xxx-xxxxxx-xxxx have already been claimed.
Cause
Assuming the number of monitored servers is less than the number of entitlements on the license, then the most common cause of this error is that you, or someone else, has been invited as a User of the license:
Resolution
Do not allocate a User to a Redgate Monitor license. Redgate Monitor is licensed by server, not user.
If you are trying to activate a perpetual license in Redgate Monitor by adding the serial key, and someone has added a user to that license, this will take all the entitlements and you'll immediately see this error when you try to add the serial key in Redgate Monitor. On Redgate Monitor licenses from red-gate.com, assigning a user to a license consumes one entitlement (not all) and you can't encounter this error. See 'Missing' License Entitlements in Redgate Monitor.
In either case, if a user has been allocated, remove it, as shown in Removing A User (Freeing Up A License/Entitlement).
Allocating an existing license to servers on new Base Monitor
In this case, the error is caused by changes made to Redgate Monitor to support the release of a new licensing model. In all supported versions, a license is now per Redgate Monitor installation (web server) rather than per base monitor. This means that if you use serial key-based activation, it's no longer possible to reuse the same serial key for a new base monitor; if you try you will see the "all entitlements claimed" error.
Resolutions
If you are on a version of Redgate Monitor before v11.2.3, and cannot currently upgrade, please open a Support ticket, briefly explaining the above situation, and they will be able to resolve it for you by splitting the license.
If you can upgrade to v11.2.3 or later, you can resolve the problem by following these steps:
- Upgrade your installation, including all base monitors, to the latest version
- Reallocate the same license by using your Redgate ID, by clicking the "Allocate your license on redgate.com" button.
- Under Additional licenses <installation name> is not using find the currently activated perpetual license. You'll see that currently the entitlements are use by other installations".
- Click Start using this license
- Return to Redgate Monitor and Deactivate your serial key-based license
In Step 2, you must allocate the license on redgate.com, rather than just by re-adding the serial key in Redgate Monitor, or it will not resolve the problem.
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