Could not load file or assembly 'Microsoft.SqlServer.ConnectionInfo, Version=16.100.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies

If you're getting the following error message in SSMS:

Could not load file or assembly 'Microsoft.SqlServer.ConnectionInfo, Version=16.100.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified. (RedGate.SqlPrompt.Shell.18)

This is a known issue in SQL Prompt which happens with SSMS 18.4.

SSMS 18.4 and earlier use version 15.0.18206.0 of Microsoft.SqlServer.ConnectionInfo, while SSMS 18.5 and later use version 16.100.0.0.  Since SQL Prompt aims to support the newer version of SSMS, it requires version 16.100.0.0 of the file, which does not exist for SSMS 18.4 and earlier.

Updating SSMS to 18.5 or later will resolve this error. If updating SSMS isn't possible, however, you can workaround this by downgrading SQL Prompt to version 10.3 which still accepts the older file: https://download.red-gate.com/checkforupdates/SQLPrompt/SQLPrompt_10.3.10.15950.exe

Was this article helpful?

1 out of 2 found this helpful
Have more questions? Submit a request