Articles
Sort by recent activity
error 5(Access is denied.) while attempting to open or create the physical file
This error can occur when using SQL Change Automation Powershell, with the default option of validating the schema folder in LocalDB, and you have LocalDB 2017 installed. This is caused by a bug in...
The target principal name is incorrect
If you receive the error message:Microsoft.Data.SqlClient.SqlException: A connection was successfully established with the server, but then an error occurred during the login process (provider: SSL...
SQL Change Automation Powershell permissions
When working with SQL Source Control Projects, SQL Change Automation PowerShell requires the same permissions as SQL Compare:Permissions required to use SQL CompareBuild step specific:Besides the p...
Body of Generated HTML Document is Blank
The body of the document you've generated using SQL Doc appears blank when you open it on a browser
To fix this, generate the documentation again with the Use frames option disabled.
This is a defa...
System.Exception: No match was found for the specified search criteria and module name 'SQLChangeAutomation'. Try Get-PSRepository to see all available registered module repositories
The SQL Change Automation add-on will attempt to download the latest version of the SQL Change Automation (SCA) Module from the PowerShell Gallery before carrying out the task at hand.
This allows ...
Sequence contains more than one matching element
The error message "Sequence contains more than one matching element" when opening SQL Multi Script can usually be worked around by recreating the Application.dat file.1. Make sure SQL Multi Script ...
The 'SqlSourceControlPackage' package did not load correctly
This issue can have multiple causes:
Using an outdated SQL Source Control version
SOC is compatible with the versions of SSMS available at the time of its release.
It is good practice to always mak...
High RAM usage in the Credential Guard service on servers hosting the Base Monitor service
DescriptionEver increased RAM usage in the Credential Guard service (lsalso.exe) in the server that hosts the Redgate Monitor Base Monitor service. Eventually, the server might crash.CausesThis app...
Could not install SqlChangeAutomation from any registered PSRepository
This can be caused by connection issues to the PowerShell Gallery or because the connection does not meet the encryption standard required to connect to the PowerShell Gallery, please see this arti...
Meanings of the colored dots in the SSMS Object Explorer for SQL Source Control
In the object explorer of SQL Server Management Studio (SSMS) SQL Source Control uses colored dots to indicate several different status types for the status of SQL Source Control or the type of cha...